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New Task Pane  
 
A new task pane was added to Office XP and now improved in 2003 to allow for easy access to 
available tasks through Microsoft Office Online. The task pane can be found on the toolbar menu: 
View > Task Pane or go to Help>Microsoft Excel Help. The Table of Contents breaks down the 
topics in Excel 2003. The task pane can either stay in place or you may close the pane.   
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Ranges 
 
A range can be selected in various ways. A continuous row of cells, an entire column, an entire 
row, non-adjacent cells and a range of any adjacent cells.  
 

 
 

                                                                         
 
 

      
Selecting A Continuous Range With The Mouse 

To select a range: 
1. Click and hold the mouse button on the upper left cell where you want the range to 

start. Select a range a1 to d10.   
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2. Drag and release the mouse to the lower right cell to be included in the range. 

 

 
 
 
 

Naming Ranges 
If your data does not have labels or if you have information stored on one worksheet that you 
want to use on other sheets, you can create a name that describes the cell or range. A 
descriptive name in a formula can make it easier to understand the purpose of the formula. For 
example, the formula =SUM(FirstMonthSales) might be easier to identify than =SUM(B2:B9). In 
this example, the name FirstMonthSales represents the range B2:B9 on the worksheet named 
Sales. 
 
Defining ranges can be accomplished in one of two ways: 

1. Manually, by typing in the range. 
2. The range can be selected on the worksheet. 

 
To manually enter the range name: 

1. Type 2.00 in cells B2 through B9 on worksheet2 
2. Highlight the range B2:B9 Select Insert/Name/Define from the menu bar or alternatively 

you can press Ctrl-F3. 

 
3. Type in the range name “FirstMonthSales”. To be acceptable, the name cannot have any 

spaces in it, must use only alphanumeric characters, and must start with at least one 
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letter, even if the rest of the “name” is numeric. 
4. Select OK.  
5. On worksheet2, in cell B11, type =sum(FirstMonthSales) and press Enter. 
6. The sum of cell B2 through B9 is now totaled in cell B11. 

 
To Use a Range 

1. Type the name anytime you would type a range. Instead of typing =Sum(B2:B9), for 
example, you can type the formula =Sum(FirstMonthSales).  

 
To Delete a Range 

1. Choose Insert>Name>Define to open the Define Name dialog box, select the range 
name that you want to delete from the list, and then click the Delete button.  

 
To Locate a Range 

1. Select F5  
2. Select the Range Name and press OK. You will be taken to that range of cells.  

 
Filling Ranges 
To fill a range: 

1. Highlight the range to be filled and type in the value 
2. Press Ctrl-Enter 
3. The Range is now changed to the new value that you entered. 

 
 

Creating a Series 
1. In a new worksheet, select cell B2 and enter 2 
2. Enter 4 in cell B3, 6 in cell B4 and 8 in cell B5 
3. If you have a particular pattern in mind, fill in three or more numbers to define the pattern 

and select the entire range to be filled. Click and drag the Fill Hand until you choose the 
appropriate range. The cell information is entered.  

4. Or, 
5. Choose Edit/Fill/Series from the “Edit” menu. 
6. When the “Series” dialog box appears (as shown in picture), change the appropriate 

boxes according to the series type. Click OK.  
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Functions 
 
Excel Functions 
Excel can be used as a very powerful tool for performing a wide variety of calculations and 
comparisons.  In this lesson we will learn how to use the many functions excel has to offer.  A 
formula expression in excel has the following structure:  an equals sign (=) followed by one or 
more operands – which can be a value, a cell reference, a range, a range name, or a function 
name.  This formula structure can be inputted manually or selected from a very complete list of 
pre-set formulas.   
 
The picture below demonstrates the manual insertion of an excel function in the formula bar 
(=A2+B2), the resulting answer can be seen in cell: C2 
 
1. Enter the following data on a new worksheet.  

 
 
AutoSum 

1. Click in the cell that should have the total. 

2. Click on the Autosum toolbar button  
3. The range is highlighted. Press Enter and the total will populate.  
 

 
Total 

1. Click in the cell that should have the total 
2. Type =sum(beginning cell ID : ending cell ID) as shown below. 
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Average 
1. Click in the cell that should have the average 

2. Click the insert formula button  
3. Click on the function name, in this case, click average and select OK. 
 

 

 
4. The average window will appear with the cells inserted. Click OK. 

 

 
 

5. The formula is automatically entered into the highlighted cell and the data shown. 
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Charts 
 
Creating Charts 
 
One of the more powerful functions of Excel is its ability to create charts.  Using the chart wizard 
you can create a chart in minutes.  Follow the steps below to learn how to create a chart. 
 

1. Enter the data (below) to be included in the chart including labels for both columns.  
2. Highlight the data including the labels as shown. 

 

 
 

3. Once the appropriate cells have been highlighted, click on the chart wizard icon 
(alternatively the chart wizard can be reached by choosing Insert/Chart from the menu 
bar). 
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4. Once the chart wizard icon has been selected you should see this screen. 
 

 
 
5. From this screen you can choose what type of chart you would like to create.  For this 
demonstration we will choose the Pie.  Once selected hit the “Next” button at the bottom.   

:  
 

This is the Chart Source screen.  
Assuming you have already selected your data, a data range (cells) can be input into the data 
range subject line.  Alternatively you can return to your worksheet (without closing this 
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window) and highlight the appropriate cells, the cell range will then be inserted into the data 
range subject line automatically. 

 
6.  Add the correct data range and hit the “next”  button.  

 
 

7. From this screen you can input Titles for the chart or axes.  The axes can also be altered; 
gridlines and legends can be removed and added.  Data labels can even be inserted into 
the graph, simply click on the appropriate tab to change the charts appearance.  Note: 
any changes made here are not final and can be changed at a later time.  Click “next” 
once the changes, if any, have been made.   
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8. The chart location screen is the final step before you see the graph. Name the sheet. 
However, if you would like to place the graph on within the worksheet as an object, select 
As object in:. 

9. Click on the “Finish” button to view your graph. 
 
 

 
 

10. Your graph has now been made; however, changes can still be made. Placing the cursor 
at the corner of the graph and dragging it to any size that is needed, can enlarge the area 
of the graph.   

11. Other changes can be made to the graph as well.  By double clicking on any element of 
the chart (lines, labels, axes, etc.), you will invoke a format dialog box to change the 
format of that particular element.  A sample format screen can be seen below.   
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 Linking Workbooks 
 

A formula that links workbooks refers to cells in more than one workbook. For example, if you 
have two workbooks that represent bills from two locations, you can write a formula that sums 
values from both workbooks. You can link worksheets in the same workbook as well.  
 
Copying data from one program to another is easy enough, but what happens if you need to 
change the data? If you simply copy the data, you must track down every file to which you copied 
the data and update the data in each file. If you link the data, any changes that you make to the 
original version of the data (the source file) automatically apply to copies of the linked data in the 
destination files.  
 

1. Open 3 new workbooks and change the view on your screen to show horizontal windows  
2. In workbook1, type the bill information from the Extended Mode section (Pg 5)  

 

 
3. In workbook2, type new data as shown below  
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4. Workbook1 and 2 should look like the following:  
 

 
 

5. In workbook3, highlight cell B2 and type = 
6. Click on tab1 in workbook1 and highlight cell B2 
7. You should now have the information shown above in workbook3. Type + 
8. Click on tab1 in workbook2 and highlight cell B2 
9. Press Enter.  
10. The totals in cell B2 from workbook1 and 2 were added, and the result stored in cell B2 of 
workbook3. 

 

 
 
Repeat steps 5-10 using new cells. Results are shown below for the first column 
 

   
Presented By   
Information Technology Services Support  14 
  



Intermediate Excel  10/3/2006 

 
 
1. Change the value in cell B2 of workbook1 to 500.00 
2. Notice that the value in cell B2 of workbook3 has changed 
3. Save your files as Book1, Book2 and Book3.  
4. Close all the files 

 
 

 
 

1. Open up Book1 and change the value in cell B2 to 150.00 
 
2. Open up Book3. You will be prompted with the following message 

 
3. Select yes. Notice that the value in workbook3 has been updated 

 

 
Whenever you change the value in either workbook1 or 2, the value will be updated in 
workbook3. This is called “linked objects”.  
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Sorting 
 

Highlight the range you want to sort, on the Data menu, click Sort… 
 

 
 
The Sort dialog box will appear.  With the Sort By dropdown list select the field to sort by, then 
select either Ascending, or Descending.  If the data starts on the first line with a header row, the 
Header row will be selected by default, you can also select No header row. Click on OK. 
 

 
 
The list will now be sorted. 
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Use AutoFilter for simple criteria and to filter by selection 
When you use the AutoFilter command, AutoFilter arrows appear to the right of the column 
labels in the filtered range. 

 

Unfiltered range 

Filtered range 

Microsoft Excel indicates the filtered items with blue. 

You use custom AutoFilter to display rows that contain either one value or another. You can also 
use custom AutoFilter to display rows that meet more than one condition for a column; for 
example, you might display rows that contain values within a specific range (such as a value of 
Davolio). 

Click any cell in the data you want to filter. On the Data menu, point to Filter, and then click 
AutoFilter.  

 

AutoFilter arrows appear to the right of each column heading. 

That's it. You're ready to filter. 

To filter the data click on one of the drop down arrows  in the column headings, and select one 
of the data elements on the list 
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there, but it's filtered out.  Also the row numbers turn blue indicating only the sorted data is being 
shown. 

Filtered product sales worksheet 

 
After you've filtered the data, you're only working with a subset of the original, full worksheet. 
Before you begin working on another filter, you need to return to the full worksheet. 
To return to the full worksheet: 

1. In the Product column, click the arrow. 
2. On the list, click (All).  

 
Lists 

 

To have Excel see this data as a list, you would click any cell within the data, point to List on the 
Data menu, and then click Create List.  
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The Create List dialog box would appear, and you would click OK, confirming that your data has 
headers (column headings) and that the indicated data is what you want included in the list. You 
could also highlight a range of cells to use it for creating a list.  

Note    If your list does not have headers, Excel will create them for you. They'll say "Column1," 
"Column2," and so on. 

Now the data is a list, and each column in the list has AutoFilter arrows at the top of the list in the 
header row. 

 

  AutoFilter arrows are automatically added in the header row. 

  A dark blue border appears around the list. 

The dark blue border around the list indicates the range of cells contained in your list. You can 
have more than one list on a worksheet when you use the List command. 
 
The dark blue border would change to a light blue border, and the arrows at the top of the list 
would disappear, if you clicked outside the list. 
 
Add a row or a column to the list 
 

 
  When another name, Callahan, is added to cell A8... 

 
  ...a new insert row is added in cell A9. 
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The row that contains an asterisk at the bottom is the insert row. As soon as you enter data to 
that row, another empty insert row is added to the list, so that you could continue to add data. If 
you clicked outside the list, the insert row and asterisk would disappear, and the list border would 
move up one row.  

You could add a column to the list just by typing in the empty column to the right. The list would 
automatically expand to include that column. 

Total values 
There's also a List toolbar in Excel 2003 which includes the Toggle Total Row button. 
This button automatically totals the last column in the list. 

 
  Click the Toggle Total Row button on the List toolbar... 

 
  ...to add a Total row to the list. 
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Pivot Tables 
 
A PivotTable report can help you see the "big picture" by summarizing and analyzing your data. 
You can control how Excel summarizes the data—for example, by sum, average, or count—
without entering a single formula. 
 
To create a Pivot Table: 
 
Open the workbook where you want to create the PivotTable report. If you're basing the 
report on an Excel list or database, click a cell in the list or database. 

1. On the Data menu, click PivotTable and PivotChart Report. 

 

2. In Step 1 of 3  Click PivotTable under What kind of report do you want to 
create?  Then Click Next > 

 

3. In step 2 of the wizard, follow the instructions for locating your data. The area of 
your spreadsheet will be highlighted with a broken line, and the range listed in the 
Range: box 
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4. Select New worksheet to put your table on a new sheet, or Existing worksheet and 
point to a location to put the Pivot Table. 

 

5. Select Layout….  Drag and drop the data you want in the table, then click OK 
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6.   You can also select Options… and make option changes then select OK 

 

 

7. Click finsh 

  

 

The Pivot table will be put in the location you selected.  From the Pivot table you can 
create reports or chats and analyze your data 
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